$re = '/^.*?[^|]$/m';
$str = 'sdlfskdjfl
dfgdfdf|
dgdsg;glkjxg;
sdfdsf|
sdfsdfsdfss
|
|
jlk
1213
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);