package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`.+_SCN(\d+(?:\.\d+)?)_.+\.csv`)
var str = `FS1_SCN0.83_axg3.csv`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}