const regex = /.+_SCN(\d+(?:\.\d+)?)_.+\.csv/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('.+_SCN(\\d+(?:\\.\\d+)?)_.+\\.csv', '')
const str = `FS1_SCN0.83_axg3.csv`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}