$re = '/.+_SCN(\d+(?:\.\d+)?)_.+\.csv/';
$str = 'FS1_SCN0.83_axg3.csv';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);