import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "rid\\=(?<rid>[^ ]+)\\s+service\\=(?<service>[^ ]+)\\s+scopes\\=(?<scopes>[^ ]+)\\s+fields\\=(?<fields>[^ ]+)\\s+issuer\\=(?<issuer>.+)\\s+empty\\=(?<empty>.*)";
final String string = "rid=iqwenoasd service=CP scopes=add-w,oot-s fields=birthdate,emails,identifier issuer=AWS CA TE empty=";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}