const regex = /rid\=(?<rid>[^ ]+)\s+service\=(?<service>[^ ]+)\s+scopes\=(?<scopes>[^ ]+)\s+fields\=(?<fields>[^ ]+)\s+issuer\=(?<issuer>.+)\s+empty\=(?<empty>.*)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('rid\\=(?<rid>[^ ]+)\\s+service\\=(?<service>[^ ]+)\\s+scopes\\=(?<scopes>[^ ]+)\\s+fields\\=(?<fields>[^ ]+)\\s+issuer\\=(?<issuer>.+)\\s+empty\\=(?<empty>.*)', 'gm')
const str = `rid=iqwenoasd service=CP scopes=add-w,oot-s fields=birthdate,emails,identifier issuer=AWS CA TE empty=`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}