re = /rid\=(?<rid>[^ ]+)\s+service\=(?<service>[^ ]+)\s+scopes\=(?<scopes>[^ ]+)\s+fields\=(?<fields>[^ ]+)\s+issuer\=(?<issuer>.+)\s+empty\=(?<empty>.*)/m
str = 'rid=iqwenoasd service=CP scopes=add-w,oot-s fields=birthdate,emails,identifier issuer=AWS CA TE empty='
# Print the match result
str.scan(re) do |match|
puts match.to_s
end