re = /(?!^.).{11}/m
str = '31415926535897932384626433832795028841971693993751058209749445923078164'
subst = '$1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result