package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\{\{\s*>\s*\w+\s*\}\}`)
var str = `<div>
<ul>
<li>{{>name}}</li>
</ul>
<div>{{>footer}}</div>
</div>
<div>
<ul>
<li>{{ > name}}</li>
</ul>
<div>{{ >footer }}</div>
</div>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}