$re = '/\{\{\s*>\s*\w+\s*\}\}/m';
$str = '<div>
<ul>
<li>{{>name}}</li>
</ul>
<div>{{>footer}}</div>
</div>
<div>
<ul>
<li>{{ > name}}</li>
</ul>
<div>{{ >footer }}</div>
</div>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);