import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\{\\{\\s*>\\s*\\w+\\s*\\}\\}";
final String string = "<div>\n"
+ " <ul>\n"
+ " <li>{{>name}}</li>\n"
+ " </ul>\n"
+ " <div>{{>footer}}</div>\n"
+ "</div>\n"
+ "<div>\n"
+ " <ul>\n"
+ " <li>{{ > name}}</li>\n"
+ " </ul>\n"
+ " <div>{{ >footer }}</div>\n"
+ "</div>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}