using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^((?:apple|mango|banana| )+) is (\d+)kg\s?$";
string input = @"apple is 2kg
apple banana mango is 2kg
apple apple apple is 6kg
banana banana banana is 6kg ";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}