$re = '/^((?:apple|mango|banana| )+) is (\d+)kg\s?$/m';
$str = 'apple is 2kg
apple banana mango is 2kg
apple apple apple is 6kg
banana banana banana is 6kg ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);