// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^((?:apple|mango|banana| )+) is (\d+)kg\s?$").unwrap();
let string = "apple is 2kg
apple banana mango is 2kg
apple apple apple is 6kg
banana banana banana is 6kg ";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}