import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[a-zA-Z]+(?=\\s+in\\s+\\[\\s*[a-zA-Z-]+(?:\\s*,\\s*[a-zA-Z-]+)*\\s*])|(?:\\G(?!^)\\s*,\\s*|(?<=[a-zA-Z])\\s+in\\s+\\[\\s*)\\K[a-zA-Z-]+(?=(?:\\s*,\\s*[a-zA-Z-]+)*\\s*])";
final String string = "location in [chambre, cuisine, salle-de-bain, jardin]";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}