re = /[a-zA-Z]+(?=\s+in\s+\[\s*[a-zA-Z-]+(?:\s*,\s*[a-zA-Z-]+)*\s*])|(?:\G(?!^)\s*,\s*|(?<=[a-zA-Z])\s+in\s+\[\s*)\K[a-zA-Z-]+(?=(?:\s*,\s*[a-zA-Z-]+)*\s*])/m
str = 'location in [chambre, cuisine, salle-de-bain, jardin]'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end