const regex = /[a-zA-Z]+(?=\s+in\s+\[\s*[a-zA-Z-]+(?:\s*,\s*[a-zA-Z-]+)*\s*])|(?:\G(?!^)\s*,\s*|(?<=[a-zA-Z])\s+in\s+\[\s*)\K[a-zA-Z-]+(?=(?:\s*,\s*[a-zA-Z-]+)*\s*])/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[a-zA-Z]+(?=\\s+in\\s+\\[\\s*[a-zA-Z-]+(?:\\s*,\\s*[a-zA-Z-]+)*\\s*])|(?:\\G(?!^)\\s*,\\s*|(?<=[a-zA-Z])\\s+in\\s+\\[\\s*)\\K[a-zA-Z-]+(?=(?:\\s*,\\s*[a-zA-Z-]+)*\\s*])', 'gm')
const str = `location in [chambre, cuisine, salle-de-bain, jardin]`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}