re = /<textarea id[^>]*>\n([^\n]*)/
str = '<div class="form-item form-type-textarea form-item-answer2">
<div class="form-textarea-wrapper resizable"><textarea id="edit-answer2" name="answer2" cols="60" rows="5" class="form-textarea">
this is some text
</textarea>
</div>
</div>'
# Print the match result
str.match(re) do |match|
puts match.to_s
end