#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\A.*(?:\r?\n(?!\w{4}-Processado\spor\sprograma\b).*)*\r?\n(\w{4})"
Local $sString = "Os bens/serviços foram colocados à disposição do adquirente em 2020-04-16 * Data/Hora início de transporte: 2020-04-16 às 11:52" & @CRLF & _
"" & @CRLF & _
"Total Líquido 500,00" & @CRLF & _
"Total de Descontos 500,00 " & @CRLF & _
"Desconto Documento " & @CRLF & _
"Total de IVA 115,00" & @CRLF & _
"Total do Documento (EUR) 615,00" & @CRLF & _
"" & @CRLF & _
"IVA Incidência Valor do IVA" & @CRLF & _
"Isento " & @CRLF & _
"6% " & @CRLF & _
"13% " & @CRLF & _
"23% 500,00 115,00 " & @CRLF & _
"" & @CRLF & _
"b5El-Processado por programa certificado n.º75/AT." & @CRLF & _
"" & @CRLF & _
"Os bens/serviços foram colocados à disposição do adquirente em 2020-04-16 * Data/Hora início de transporte: 2020-04-16 às 11:52" & @CRLF & _
"" & @CRLF & _
"Total Líquido 500,00" & @CRLF & _
"Total de Descontos 500,00 " & @CRLF & _
"Desconto Documento " & @CRLF & _
"Total de IVA 115,00" & @CRLF & _
"Total do Documento (EUR) 615,00" & @CRLF & _
"" & @CRLF & _
"IVA Incidência Valor do IVA" & @CRLF & _
"Isento " & @CRLF & _
"6% " & @CRLF & _
"13% " & @CRLF & _
"23% 500,00 115,00 " & @CRLF & _
"" & @CRLF & _
"b5El-Processado por programa certificado n.º75/AT." & @CRLF & _
"" & @CRLF & _
"Os bens/serviços foram colocados à disposição do adquirente em 2020-04-16 * Data/Hora início de transporte: 2020-04-16 às 11:52" & @CRLF & _
"" & @CRLF & _
"Total Líquido 500,00" & @CRLF & _
"Total de Descontos 500,00 " & @CRLF & _
"Desconto Documento " & @CRLF & _
"Total de IVA 115,00" & @CRLF & _
"Total do Documento (EUR) 615,00" & @CRLF & _
"" & @CRLF & _
"IVA Incidência Valor do IVA" & @CRLF & _
"Isento " & @CRLF & _
"6% " & @CRLF & _
"13% " & @CRLF & _
"23% 500,00 115,00 " & @CRLF & _
"" & @CRLF & _
"b5El-Processado por programa certificado n.º75/AT."
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")