import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\A.*(?:\\r?\\n(?!\\w{4}-Processado\\spor\\sprograma\\b).*)*\\r?\\n(\\w{4})";
final String string = "Os bens/serviços foram colocados à disposição do adquirente em 2020-04-16 * Data/Hora início de transporte: 2020-04-16 às 11:52\n\n"
+ "Total Líquido 500,00\n"
+ "Total de Descontos 500,00 \n"
+ "Desconto Documento \n"
+ "Total de IVA 115,00\n"
+ "Total do Documento (EUR) 615,00\n\n"
+ "IVA Incidência Valor do IVA\n"
+ "Isento \n"
+ "6% \n"
+ "13% \n"
+ "23% 500,00 115,00 \n\n"
+ "b5El-Processado por programa certificado n.º75/AT.\n\n"
+ "Os bens/serviços foram colocados à disposição do adquirente em 2020-04-16 * Data/Hora início de transporte: 2020-04-16 às 11:52\n\n"
+ "Total Líquido 500,00\n"
+ "Total de Descontos 500,00 \n"
+ "Desconto Documento \n"
+ "Total de IVA 115,00\n"
+ "Total do Documento (EUR) 615,00\n\n"
+ "IVA Incidência Valor do IVA\n"
+ "Isento \n"
+ "6% \n"
+ "13% \n"
+ "23% 500,00 115,00 \n\n"
+ "b5El-Processado por programa certificado n.º75/AT.\n\n"
+ "Os bens/serviços foram colocados à disposição do adquirente em 2020-04-16 * Data/Hora início de transporte: 2020-04-16 às 11:52\n\n"
+ "Total Líquido 500,00\n"
+ "Total de Descontos 500,00 \n"
+ "Desconto Documento \n"
+ "Total de IVA 115,00\n"
+ "Total do Documento (EUR) 615,00\n\n"
+ "IVA Incidência Valor do IVA\n"
+ "Isento \n"
+ "6% \n"
+ "13% \n"
+ "23% 500,00 115,00 \n\n"
+ "b5El-Processado por programa certificado n.º75/AT.";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}