import Foundation
let pattern = #"\A.*(?:\r?\n(?!\w{4}-Processado\spor\sprograma\b).*)*\r?\n(\w{4})"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
Os bens/serviços foram colocados à disposição do adquirente em 2020-04-16 * Data/Hora início de transporte: 2020-04-16 às 11:52
Total Líquido 500,00
Total de Descontos 500,00
Desconto Documento
Total de IVA 115,00
Total do Documento (EUR) 615,00
IVA Incidência Valor do IVA
Isento
6%
13%
23% 500,00 115,00
b5El-Processado por programa certificado n.º75/AT.
Os bens/serviços foram colocados à disposição do adquirente em 2020-04-16 * Data/Hora início de transporte: 2020-04-16 às 11:52
Total Líquido 500,00
Total de Descontos 500,00
Desconto Documento
Total de IVA 115,00
Total do Documento (EUR) 615,00
IVA Incidência Valor do IVA
Isento
6%
13%
23% 500,00 115,00
b5El-Processado por programa certificado n.º75/AT.
Os bens/serviços foram colocados à disposição do adquirente em 2020-04-16 * Data/Hora início de transporte: 2020-04-16 às 11:52
Total Líquido 500,00
Total de Descontos 500,00
Desconto Documento
Total de IVA 115,00
Total do Documento (EUR) 615,00
IVA Incidência Valor do IVA
Isento
6%
13%
23% 500,00 115,00
b5El-Processado por programa certificado n.º75/AT.
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)