#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?s)(\w+)\s=\s(.+?)(?=$|\n[A-Z])"
Local $sString = "CONTENT = ALL" & @CRLF & _
"TABLES = TEST.RAW_1" & @CRLF & _
" , TEST.RAW_2" & @CRLF & _
" , TEST.RAW_3" & @CRLF & _
" , TEST.RAW_4" & @CRLF & _
"PARALLEL = 4"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")