import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\w+)\\s=\\s(.+?)(?=$|\\n[A-Z])";
final String string = "CONTENT = ALL\n"
+ "TABLES = TEST.RAW_1\n"
+ " , TEST.RAW_2\n"
+ " , TEST.RAW_3\n"
+ " , TEST.RAW_4\n"
+ "PARALLEL = 4";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}