re = /(\w+)\s=\s(.+?)(?=$|\n[A-Z])/
str = 'CONTENT = ALL
TABLES = TEST.RAW_1
, TEST.RAW_2
, TEST.RAW_3
, TEST.RAW_4
PARALLEL = 4'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end