#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?=(?:\D*\d){1,9}\D*$)\d*(?:\.\d{2})?$"
Local $sString = "Match type:" & @CRLF & _
"" & @CRLF & _
".01" & @CRLF & _
"1" & @CRLF & _
"1.01" & @CRLF & _
"0" & @CRLF & _
"1234567.89" & @CRLF & _
"" & @CRLF & _
"Unmatch type:" & @CRLF & _
"" & @CRLF & _
".012" & @CRLF & _
"1.098" & @CRLF & _
"123.456"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")