$re = '/^(?=(?:\D*\d){1,9}\D*$)\d*(?:\.\d{2})?$/m';
$str = 'Match type:
.01
1
1.01
0
1234567.89
Unmatch type:
.012
1.098
123.456';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);