using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?=\*).*$";
string input = @"* Say ""hello"" to ""world""
* Say <something> to <somebody>
* I can also be a plain statement
I can also be a plain statement";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}