re = /^(?=\*).*$/m
str = '* Say "hello" to "world"
* Say <something> to <somebody>
* I can also be a plain statement
I can also be a plain statement'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end