$re = '/^(?=\*).*$/m';
$str = '* Say "hello" to "world"
* Say <something> to <somebody>
* I can also be a plain statement
I can also be a plain statement';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);