#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(^(?:\/(_next\/data\/[^\/]{1,}))?(?:\/(?<i18n_locale>(?!_next\/)(en|de)))(?<user_matcher_from_i18n_pattern>\/((?!api|_next\/static|_next\/image|favicon.ico|sitemap.xml|robots.txt).*))(\.json)?[\/#\?]?$)|(^(?<user_matcher_from_base_matcher>\/((?!api|_next\/static|_next\/image|favicon.ico|sitemap.xml|robots.txt).*))[\/#\?]?$)"
Local $sString = "/api/some-api-route" & @CRLF & _
"/de/some-page-for-de-locale" & @CRLF & _
"/some-page-for-default-locale" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")