import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(^(?:\\/(_next\\/data\\/[^\\/]{1,}))?(?:\\/(?<i18n_locale>(?!_next\\/)(en|de)))(?<user_matcher_from_i18n_pattern>\\/((?!api|_next\\/static|_next\\/image|favicon.ico|sitemap.xml|robots.txt).*))(\\.json)?[\\/#\\?]?$)|(^(?<user_matcher_from_base_matcher>\\/((?!api|_next\\/static|_next\\/image|favicon.ico|sitemap.xml|robots.txt).*))[\\/#\\?]?$)";
final String string = "/api/some-api-route\n"
+ "/de/some-page-for-de-locale\n"
+ "/some-page-for-default-locale\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}