const regex = /(^(?:\/(_next\/data\/[^\/]{1,}))?(?:\/(?<i18n_locale>(?!_next\/)(en|de)))(?<user_matcher_from_i18n_pattern>\/((?!api|_next\/static|_next\/image|favicon.ico|sitemap.xml|robots.txt).*))(\.json)?[\/#\?]?$)|(^(?<user_matcher_from_base_matcher>\/((?!api|_next\/static|_next\/image|favicon.ico|sitemap.xml|robots.txt).*))[\/#\?]?$)/mg;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(^(?:\\\/(_next\\\/data\\\/[^\\\/]{1,}))?(?:\\\/(?<i18n_locale>(?!_next\\\/)(en|de)))(?<user_matcher_from_i18n_pattern>\\\/((?!api|_next\\\/static|_next\\\/image|favicon.ico|sitemap.xml|robots.txt).*))(\\.json)?[\\\/#\\?]?$)|(^(?<user_matcher_from_base_matcher>\\\/((?!api|_next\\\/static|_next\\\/image|favicon.ico|sitemap.xml|robots.txt).*))[\\\/#\\?]?$)', 'mg')
const str = `/api/some-api-route
/de/some-page-for-de-locale
/some-page-for-default-locale
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}