import Foundation
let pattern = #"(?:call|CALL)[\ *](?:(?:system|"system").(?:runtime|"runtime").(?:kill_query|"kill_query"))"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
CALL system.runtime.kill_query(query_id => '20211003_215635_15007_n3mb3', message => 'Looker query cancel.')
CALL "system"."runtime"."kill_query"(query_id => '20211003_215635_15007_n3mb3', message => 'Looker query cancel.')
CALL "system".runtime."kill_query"(query_id => '20211003_215635_15007_n3mb3', message => 'Looker query cancel.')
CALL "system"."runtime"."kill_query"('20211003_215635_15007_n3mb3', 'afsd')
CALL "system"."runtime"."kill_query"(message => '20211003_215635_15007_n3mb3', query_id => 'afsd')
CALL+"system"."runtime"."kill_query"(message => '20211003_215635_15007_n3mb3', query_id => 'afsd')
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)