$re = '/ordernr[\r\n]+([^\r\n]+)/six';
$str = ' 1. 21Sid1
2. Ordernr
3. E17222
4. By
5. Seller';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);