const regex = new RegExp('\\({.*?/ / }\\)', 'g')
const str = `NULL ({ }) Regina Shueller ({ 5 p1 p2 }) works ({ some text }) for ({ / / }) Italy ({ 14 / / }) 's ({ 15 / / }) La ({ 16 / / }) Repubblica ({ 17 / / }) newspaper ({ 18 / / }) . ({ 38 / / })`;
const subst = ` `;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);