import re
regex = re.compile(r"\({.*?/ / }\)")
test_str = "NULL ({ }) Regina Shueller ({ 5 p1 p2 }) works ({ some text }) for ({ / / }) Italy ({ 14 / / }) 's ({ 15 / / }) La ({ 16 / / }) Repubblica ({ 17 / / }) newspaper ({ 18 / / }) . ({ 38 / / })"
subst = " "
result = regex.sub(subst, test_str)
if result:
print(result)