package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^[\s]*([\w]+)[\s]*\([\s]*"([^"]+)"[\s]*,`)
var str = ` DocParam("Guid", "id", "Active Session unique ID.")
`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}