#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\b([0-9]{6})\b"
Local $sString = "<div dir="ltr"><br><br><div class="gmail_quote"><div dir="ltr" class="gmail_attr"><br></div><u></u>" & @CRLF & _
" <div>" & @CRLF & _
" <center id="m_-2051398760120817894wrapper">" & @CRLF & _
" <table id="m_-2051398760120817894main" width="100%">" & @CRLF & _
" <tbody><tr id="m_-2051398760120817894logo">" & @CRLF & _
" <td>" & @CRLF & _
" <table width="100%">" & @CRLF & _
" <tbody><tr>" & @CRLF & _
" <td>" & @CRLF & _
" <img src="test.com/logo.png" width="140px" alt="xxxxx Logo" style="padding:0 10px">" & @CRLF & _
" </td>" & @CRLF & _
" </tr>" & @CRLF & _
" </tbody></table>" & @CRLF & _
" </td>" & @CRLF & _
" </tr>" & @CRLF & _
" <tr>" & @CRLF & _
" <td height="18px"></td>" & @CRLF & _
" </tr>" & @CRLF & _
" <tr id="m_-2051398760120817894header">" & @CRLF & _
" <td>" & @CRLF & _
" <table width="100%">" & @CRLF & _
" <tbody><tr>" & @CRLF & _
" <td height="64px" style="background-color:#10069f;color:#fff;padding-left:24px;font-weight:700">Reset your password</td>" & @CRLF & _
" </tr>" & @CRLF & _
" </tbody></table>" & @CRLF & _
" </td>" & @CRLF & _
" </tr>" & @CRLF & _
" <tr id="m_-2051398760120817894content">" & @CRLF & _
" <td>" & @CRLF & _
" <table width="100%">" & @CRLF & _
" <tbody><tr>" & @CRLF & _
" <td style="background-color:#f6f5ff;padding:24px 24px 16px 24px">" & @CRLF & _
" <p style="margin-top:0">The following is the verification code required to complete your password reset.</p>" & @CRLF & _
" <p style="margin-bottom:24px">Enter the following verification code on the screen during the registration, and proceed to the next step.</p>" & @CRLF & _
" <div style="display:block;text-align:center;margin-bottom:8px;background-color:#fff;height:92px;font-weight:600;font-size:36px;line-height:92px">191418</div>" & @CRLF & _
" <span style="display:block;font-size:12px;color:#5d5d5d">*The verification code is valid only for 24 hours.</span>" & @CRLF & _
" </td>" & @CRLF & _
" </tr>" & @CRLF & _
" </tbody></table>" & @CRLF & _
" </td>" & @CRLF & _
" </tr>" & @CRLF & _
" <tr>" & @CRLF & _
" <td height="24px"></td>" & @CRLF & _
" </tr>" & @CRLF & _
" <tr id="m_-2051398760120817894footer">" & @CRLF & _
" <td>" & @CRLF & _
" <table width="100%">" & @CRLF & _
" <tbody><tr>" & @CRLF & _
" <td style="background-color:#6d7777;padding:16px 24px;font-size:12px;color:#fff">" & @CRLF & _
" <table width="100%">" & @CRLF & _
" <tbody><tr>" & @CRLF & _
" <td id="m_-2051398760120817894footer-left">" & @CRLF & _
" <span style="display:block">amnimo Inc.</span>" & @CRLF & _
" <span style="display:block">0-3-30 usaa-fso, xxxxxxxx-shi, Tokyo, 180-8750, Japan</span>" & @CRLF & _
" <span style="display:block">Phone: +81-422-52-6779</span>" & @CRLF & _
" <span id="m_-2051398760120817894copyright-mb" style="margin-top:16px">© 2020 <div dir="ltr"><br><br><div class="gmail_quote"><div dir="ltr" class="gmail_attr"><br></div><u></u>" & @CRLF & _
"<div>" & @CRLF & _
" <center id="m_-2051398760120817894wrapper">" & @CRLF & _
" <table id="m_-2051398760120817894main" width="100%">" & @CRLF & _
" <tbody><tr id="m_-2051398760120817894logo">" & @CRLF & _
" <td>" & @CRLF & _
" <table width="100%">" & @CRLF & _
" <tbody><tr>" & @CRLF & _
" <td>" & @CRLF & _
" <img src="https://test.com/logo.png" width="140px" alt="Amnimo Logo" style="padding:0 10px">" & @CRLF & _
" </td>" & @CRLF & _
" </tr>" & @CRLF & _
" </tbody></table>" & @CRLF & _
" </td>" & @CRLF & _
" </tr>" & @CRLF & _
" <tr>" & @CRLF & _
" <td height="18px"></td>" & @CRLF & _
" </tr>" & @CRLF & _
" <tr id="m_-2051398760120817894header">" & @CRLF & _
" <td>" & @CRLF & _
" <table width="100%">" & @CRLF & _
" <tbody><tr>" & @CRLF & _
" <td height="64px" style="background-color:#10069f;color:#fff;padding-left:24px;font-weight:700">Reset your password</td>" & @CRLF & _
" </tr>" & @CRLF & _
" </tbody></table>" & @CRLF & _
" </td>" & @CRLF & _
" </tr>" & @CRLF & _
" <tr id="m_-2051398760120817894content">" & @CRLF & _
" <td>" & @CRLF & _
" <table width="100%">" & @CRLF & _
" <tbody><tr>" & @CRLF & _
" <td style="background-color:#f6f5ff;padding:24px 24px 16px 24px">" & @CRLF & _
" <p style="margin-top:0">The following is the verification code required to complete your password reset.</p>" & @CRLF & _
" <p style="margin-bottom:24px">Enter the following verification code on the screen during the registration, and proceed to the next step.</p>" & @CRLF & _
" <div style="display:block;text-align:center;margin-bottom:8px;background-color:#fff;height:92px;font-weight:600;font-size:36px;line-height:92px">191418</div>" & @CRLF & _
" <span style="display:block;font-size:12px;color:#5d5d5d">*The verification code is valid only for 24 hours.</span>" & @CRLF & _
" </td>" & @CRLF & _
" </tr>" & @CRLF & _
" </tbody></table>" & @CRLF & _
" </td>" & @CRLF & _
" </tr>" & @CRLF & _
" <tr>" & @CRLF & _
" <td height="24px"></td>" & @CRLF & _
" </tr>" & @CRLF & _
" <tr id="m_-2051398760120817894footer">" & @CRLF & _
" <td>" & @CRLF & _
" <table width="100%">" & @CRLF & _
" <tbody><tr>" & @CRLF & _
" <td style="background-color:#6d7777;padding:16px 24px;font-size:12px;color:#fff">" & @CRLF & _
" <table width="100%">" & @CRLF & _
" <tbody><tr>" & @CRLF & _
" <td id="m_-2051398760120817894footer-left">" & @CRLF & _
" <span style="display:block">test Inc.</span>" & @CRLF & _
" <span style="display:block">2-9-32 ssdsa-sss, puakano-shi, Tokyo, 000-8000, Japan</span>" & @CRLF & _
" <span style="display:block">Phone: +81-000-00-652</span>" & @CRLF & _
" <span id="m_-2051398760120817894copyright-mb" style="margin-top:16px">© 2020 amnimo Inc.</span>" & @CRLF & _
" </td>" & @CRLF & _
" <td id="m_-2051398760120817894footer-right">" & @CRLF & _
" <span style="display:block">© 2020 amnimo Inc.</span>" & @CRLF & _
" </td>" & @CRLF & _
" </tr>" & @CRLF & _
" </tbody></table>" & @CRLF & _
" </td>" & @CRLF & _
" </tr>" & @CRLF & _
" </tbody></table>" & @CRLF & _
" </td>" & @CRLF & _
" </tr>" & @CRLF & _
" </tbody></table>" & @CRLF & _
" </center>" & @CRLF & _
"</div>" & @CRLF & _
"</div></div> Inc.</span>" & @CRLF & _
" </td>" & @CRLF & _
" <td id="m_-2051398760120817894footer-right">" & @CRLF & _
" <span style="display:block">© 2020 test Inc.</span>" & @CRLF & _
" </td>" & @CRLF & _
" </tr>" & @CRLF & _
" </tbody></table>" & @CRLF & _
" </td>" & @CRLF & _
" </tr>" & @CRLF & _
" </tbody></table>" & @CRLF & _
" </td>" & @CRLF & _
" </tr>" & @CRLF & _
" </tbody></table>" & @CRLF & _
" </center>" & @CRLF & _
" </div>" & @CRLF & _
" </div></div>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")