// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\b([0-9]{6})\b").unwrap();
let string = "<div dir=\"ltr\"><br><br><div class=\"gmail_quote\"><div dir=\"ltr\" class=\"gmail_attr\"><br></div><u></u>
<div>
<center id=\"m_-2051398760120817894wrapper\">
<table id=\"m_-2051398760120817894main\" width=\"100%\">
<tbody><tr id=\"m_-2051398760120817894logo\">
<td>
<table width=\"100%\">
<tbody><tr>
<td>
<img src=\"test.com/logo.png\" width=\"140px\" alt=\"xxxxx Logo\" style=\"padding:0 10px\">
</td>
</tr>
</tbody></table>
</td>
</tr>
<tr>
<td height=\"18px\"></td>
</tr>
<tr id=\"m_-2051398760120817894header\">
<td>
<table width=\"100%\">
<tbody><tr>
<td height=\"64px\" style=\"background-color:#10069f;color:#fff;padding-left:24px;font-weight:700\">Reset your password</td>
</tr>
</tbody></table>
</td>
</tr>
<tr id=\"m_-2051398760120817894content\">
<td>
<table width=\"100%\">
<tbody><tr>
<td style=\"background-color:#f6f5ff;padding:24px 24px 16px 24px\">
<p style=\"margin-top:0\">The following is the verification code required to complete your password reset.</p>
<p style=\"margin-bottom:24px\">Enter the following verification code on the screen during the registration, and proceed to the next step.</p>
<div style=\"display:block;text-align:center;margin-bottom:8px;background-color:#fff;height:92px;font-weight:600;font-size:36px;line-height:92px\">191418</div>
<span style=\"display:block;font-size:12px;color:#5d5d5d\">*The verification code is valid only for 24 hours.</span>
</td>
</tr>
</tbody></table>
</td>
</tr>
<tr>
<td height=\"24px\"></td>
</tr>
<tr id=\"m_-2051398760120817894footer\">
<td>
<table width=\"100%\">
<tbody><tr>
<td style=\"background-color:#6d7777;padding:16px 24px;font-size:12px;color:#fff\">
<table width=\"100%\">
<tbody><tr>
<td id=\"m_-2051398760120817894footer-left\">
<span style=\"display:block\">amnimo Inc.</span>
<span style=\"display:block\">0-3-30 usaa-fso, xxxxxxxx-shi, Tokyo, 180-8750, Japan</span>
<span style=\"display:block\">Phone: +81-422-52-6779</span>
<span id=\"m_-2051398760120817894copyright-mb\" style=\"margin-top:16px\">© 2020 <div dir=\"ltr\"><br><br><div class=\"gmail_quote\"><div dir=\"ltr\" class=\"gmail_attr\"><br></div><u></u>
<div>
<center id=\"m_-2051398760120817894wrapper\">
<table id=\"m_-2051398760120817894main\" width=\"100%\">
<tbody><tr id=\"m_-2051398760120817894logo\">
<td>
<table width=\"100%\">
<tbody><tr>
<td>
<img src=\"https://test.com/logo.png\" width=\"140px\" alt=\"Amnimo Logo\" style=\"padding:0 10px\">
</td>
</tr>
</tbody></table>
</td>
</tr>
<tr>
<td height=\"18px\"></td>
</tr>
<tr id=\"m_-2051398760120817894header\">
<td>
<table width=\"100%\">
<tbody><tr>
<td height=\"64px\" style=\"background-color:#10069f;color:#fff;padding-left:24px;font-weight:700\">Reset your password</td>
</tr>
</tbody></table>
</td>
</tr>
<tr id=\"m_-2051398760120817894content\">
<td>
<table width=\"100%\">
<tbody><tr>
<td style=\"background-color:#f6f5ff;padding:24px 24px 16px 24px\">
<p style=\"margin-top:0\">The following is the verification code required to complete your password reset.</p>
<p style=\"margin-bottom:24px\">Enter the following verification code on the screen during the registration, and proceed to the next step.</p>
<div style=\"display:block;text-align:center;margin-bottom:8px;background-color:#fff;height:92px;font-weight:600;font-size:36px;line-height:92px\">191418</div>
<span style=\"display:block;font-size:12px;color:#5d5d5d\">*The verification code is valid only for 24 hours.</span>
</td>
</tr>
</tbody></table>
</td>
</tr>
<tr>
<td height=\"24px\"></td>
</tr>
<tr id=\"m_-2051398760120817894footer\">
<td>
<table width=\"100%\">
<tbody><tr>
<td style=\"background-color:#6d7777;padding:16px 24px;font-size:12px;color:#fff\">
<table width=\"100%\">
<tbody><tr>
<td id=\"m_-2051398760120817894footer-left\">
<span style=\"display:block\">test Inc.</span>
<span style=\"display:block\">2-9-32 ssdsa-sss, puakano-shi, Tokyo, 000-8000, Japan</span>
<span style=\"display:block\">Phone: +81-000-00-652</span>
<span id=\"m_-2051398760120817894copyright-mb\" style=\"margin-top:16px\">© 2020 amnimo Inc.</span>
</td>
<td id=\"m_-2051398760120817894footer-right\">
<span style=\"display:block\">© 2020 amnimo Inc.</span>
</td>
</tr>
</tbody></table>
</td>
</tr>
</tbody></table>
</td>
</tr>
</tbody></table>
</center>
</div>
</div></div> Inc.</span>
</td>
<td id=\"m_-2051398760120817894footer-right\">
<span style=\"display:block\">© 2020 test Inc.</span>
</td>
</tr>
</tbody></table>
</td>
</tr>
</tbody></table>
</td>
</tr>
</tbody></table>
</center>
</div>
</div></div>";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}