using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?P<name>.+?)(?:\s+(?P<id>\d+))?$";
string input = @"Mr. John Smith 1111
Mr. John12 Smith 1111
Mr. John12 Smith223 1111";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}