re = /^(?P<name>.+?)(?:\s+(?P<id>\d+))?$/m
str = 'Mr. John Smith 1111
Mr. John12 Smith 1111
Mr. John12 Smith223 1111'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end