package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?P<name>.+?)(?:\s+(?P<id>\d+))?$`)
var str = `Mr. John Smith 1111
Mr. John12 Smith 1111
Mr. John12 Smith223 1111`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}