import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?=.{0,50}$)^((https?:\\/\\/)?(www\\.)?)?([a-zA-Z0-9&\\-\\'\\+\\$%_,\\/;#])+\\.([a-z]){2,4}$";
final String string = "www.com";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}