import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\[\\d{4}\\/\\d{2}\\/\\d{2}[^\\]]*](.*?)(?=^\\[\\d{4}\\/\\d{2}\\/\\d{2}[^\\]]*])|^\\[\\d{4}\\/\\d{2}\\/\\d{2}[^\\]]*](.*?)(?!.)";
final String string = "[1234/12/12 time] Entry\n"
+ "foo\n"
+ "[1234/12/12 time] Entry\n"
+ "[1234/12/12 time] Entry\n"
+ "[1234/12/12 time] Entry";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}