re = /^\[\d{4}\/\d{2}\/\d{2}[^\]]*](.*?)(?=^\[\d{4}\/\d{2}\/\d{2}[^\]]*])|^\[\d{4}\/\d{2}\/\d{2}[^\]]*](.*?)(?!.)/m
str = '[1234/12/12 time] Entry
foo
[1234/12/12 time] Entry
[1234/12/12 time] Entry
[1234/12/12 time] Entry'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end