$re = '/^\[\d{4}\/\d{2}\/\d{2}[^\]]*](.*?)(?=^\[\d{4}\/\d{2}\/\d{2}[^\]]*])|^\[\d{4}\/\d{2}\/\d{2}[^\]]*](.*?)(?!.)/ms';
$str = '[1234/12/12 time] Entry
foo
[1234/12/12 time] Entry
[1234/12/12 time] Entry
[1234/12/12 time] Entry';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);