using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^09\d{10}";
string input = @"091212345567";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}