$re = '/^09\d{10}/';
$str = '091212345567';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);