package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^09\d{10}`)
var str = `091212345567`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}