#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(Ausdruck1|Ausdruck2|Ausdruck3)(?=.*AusdruckA)"
Local $sString = "Ausdruckc123 !!!Ausdruck3 AusdruckA" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")